唯品秀前端博客

这个需求可能不是很常见,但最近在玩Vite+Vue3时候明显发现相关的一些插件库高速迭代,因为技术较新所以坑多,有时候你好不容易找到解决办法,官方其实已经在修复了,只需要手动更新下对应的包即可,既然是前沿实验性的东西,那自然隔三差五我都想让自己的所有依赖包处于最新状态,能避免一些坑从而不必做一些无用功,如何做?如下

安装插件

1
npm install -g npm-check-updates

使用

检查package.json中所有可更新的包

1
ncu

检查devDependencies中可以更新的版本

1
ncu -m

更新所有依赖到新版本

1
ncu -u   // 注意,更新的只是package.json下依赖的版本号

重新npm

1
npm install   // 要是不放心,可以先把所有包删除,再重新npm install
本站所有文章、图片、资源等如无特殊说明或标注,均为来自互联网或者站长原创,版权归原作者所有;仅作为个人学习、研究以及欣赏!如若本站内容侵犯了原著者的合法权益,可联系我们进行处理,邮箱:343049466@qq.com
赞(0) 打赏
标签:

上一篇:

下一篇:

相关推荐

0 条评论关于"npm升级package.json中所有依赖包到最新版本"

表情

最新评论

    暂无留言哦~~
谢谢你请我吃鸡腿*^_^*

支付宝扫一扫打赏

微信扫一扫打赏